Jump to content
Caseyrhe

70 Landau Coupe Special

Recommended Posts

On 4/27/2020 at 9:44 PM, Caseyrhe said:

Nothing will surprise me after this one. Cut the Upolstrey off the seat to start the process of recovering it and bam! Someone used diapers to cover the springs and for the padding. Fairly new ones at that due to the peel and stick. 

 

 

 

Actually that is a good idea; just make sure to use new ones, not used :)

Share this post


Link to post
Share on other sites
30 minutes ago, Caseyrhe said:

I thought it was a pretty CRAPPY thing to do

Are you going to keep it or replace it? What are you going to use as replacement, foam or make cotton padding like originals?

Share this post


Link to post
Share on other sites

Making good progress. Is that a 70 seat belt or 69 you are using? I thought 70 had one buckle that the retrectable catch hooked on and the shoulder belt clipped to the slot on retractable catch.

Share this post


Link to post
Share on other sites

Have made a lot of progress, exterior pretty much done but rocker panels and grill. Interior is complete less package tray that I need to build. Motor is in and at first attempt to fire up, when filling with Wtr, found two leaks. Leaks where from both heads, where they meet the block. 3 steps forward 2 steps back right! Machine shop jacked the heads up and had to resurface them. Before reinstalling the headers at second attempt, all was good with no leaks. I have to say, I’m getting good at bolting up the headers and have quite the array of altered 7/16 wrenches for the job. Less than 3 hours for both this time  

 

B6C6F044-2A2F-4E77-AD41-E043955BE92C.jpeg

234FA5FB-8280-440B-BF61-3CD8CB4832CA.jpeg

908E2E88-B1EE-4647-A597-BD9519CADEAC.jpeg

Share this post


Link to post
Share on other sites

Here’s another step back. While I had the heads off, figured I would replace the proportioning valve. Guess someone was playing a joke and affixed bracket on yo valve opposite. Good thing I was able to rebuild old one with guys from new one

0D215ECC-EC9E-40C2-A298-227A586125E5.png

Share this post


Link to post
Share on other sites

If I could just get a break. I needed a carb for the 390, so I bought a Holley 770, auto choke, brand spanking new. Installed with 1” factory spacer. Upon initial startup, can not adjust idle to hold rpms above 2k to break in cam, but can manually hold throttle open to keep rpms above 2k. 
 

Any ideals??

Share this post


Link to post
Share on other sites
On 4/27/2020 at 6:44 PM, Caseyrhe said:

Nothing will surprise me after this one. Cut the Upolstrey off the seat to start the process of recovering it and bam! Someone used diapers to cover the springs and for the padding. Fairly new ones at that due to the peel and stick. 

F1E09169-C75A-42D2-BEEA-1E13E6BAB278.jpeg

5125AFAE-EDAE-4774-BB24-BE9051D188FA.jpeg

7D0E8729-EDF0-43CF-9D6C-38EB990F38D0.jpeg

You have to do what you have to do do !

Share this post


Link to post
Share on other sites

This car is going to kill me. Never have I had so many issues!

Fired it back up today after replacing carb and spacer gaskets. Disconnected all the vac lines. Leaning the choke all the way. Fired right up, but would still not idle above 2k with idle screw all the way down, so I held the idle up by hand for another 10 min, with temp running at 190. 
Well, I’m going to say it would idle due to being under a load, rebuilt C6 is the prob. Trans started over heating, shot fluid out the vent hole, and caught on fire. Shut the car off, grabbed the closely placed fire ext and put it out. Guess a def pump or ???? Fluid looks like mtr oil, shop smells like burnt pop corn. 
Just kill me now!!

Share this post


Link to post
Share on other sites

Just in case your wondering,,a C6 will not come out without removing one header. I’m getting damn good with these headers, third time on pass side now in 4-5 weeks. 
Here’s the C6, think it got a little hot? 

4992D062-46A3-432E-AD6E-C1D37EA742E6.jpeg

DCFE44B0-151E-43FA-86E4-92DA8597F13F.jpeg

7B07304A-919B-4EB2-8465-105B53516B98.jpeg

Share this post


Link to post
Share on other sites

The torque conv was blue new. Going to check the flywheel in a few days, I’m sure I just better replace it now instead of next week, lol.
Transmission shop said he’ll fix it for me at no charge. Not sure I’m to trusting with his work right now. 

Share this post


Link to post
Share on other sites

Got her running today, finished breaking in the cam and then idled her down. Used the bell housing for a Std and only used about 7 bolts to hold the headers on. 
Just need to take all that loose and wait. Sure would be nice to get the Tranny back by Friday drive it next weekend. 

Share this post


Link to post
Share on other sites

Sounds healthy.   When you get a chance could you get a couple of pictures from different angles and standing on a ladder looking at the hood closed.  I'm assuming you did the 69 Mach 1 blackout hood treatment on it? Flat or?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...