Jump to content
Kris

69 Convertible build

Recommended Posts

Been a while since I posted on my build thread. Been doing pre paint body work. Today I got all the interior of the car, the interior doors, trunk lid, and door hinges all primed. I plan on painting the interior tomorrow if I have time and the weather let’s me. 

D6E5954D-103B-4305-BA1E-521DE7A29FE6.jpeg

251A353E-C8C3-4DE3-ADDE-B311301C8DE2.jpeg

Share this post


Link to post
Share on other sites

Got all the interior color done. Still have clear to do This afternoon but it looks good. The color is F8 green. It’s a 2019 dodge color. The first picture doesn’t do it justice due to being in the shade and no clear on it. You can see the metal flake and more of the actual color in the last picture. 

09CF0888-29CB-418D-BD65-D6E707604B23.jpeg

A7675C59-BC26-4659-9F51-73FD01DA322F.jpeg

F09CDC32-DFB5-4C5F-BE26-D9967E9E247D.jpeg

3DDCDB1B-893D-46CF-98E2-2904E414CF03.jpeg

Share this post


Link to post
Share on other sites

Your paint job looks awesome and it's also a good Idea to install jute or felt on top of the foil as well, for heat and sound.

 

Share this post


Link to post
Share on other sites

Been a while since I posted an update but over the last couple of weeks I finished the brake system and now have fully functional brakes. I also installed the under dash portion of my vintage air AC system. This last weekend I installed my lower dash and the wiring harness, along with the steering column and steering wheel. 

11A3AEC0-71EF-4856-9BE1-5CF621DC1F7C.jpeg

Share this post


Link to post
Share on other sites

This weekend I finished final prep on the fenders before pain. I also installed the fuel lines, drilled the hood for a Mach 1 style scoop, drilled the doors for mirrors, and painted then installed the hood hinges. 

Share this post


Link to post
Share on other sites

Progress was a little slow the last month or so. I injured my right hand and couldn’t really use it. Back to 100% now and making progress. I put the motor and trans back in yesterday. Today I installed the power steering, tri-y long tube headers, and the ac compressor / brackets. Also finished up some wiring, and installed the heater hoses. 

02B236DF-A30C-42B2-A0E2-960B17BB4117.jpeg

Share this post


Link to post
Share on other sites

Been working on finishing up some of the engine bay but I’m waiting on a few parts to get it wrapped up. I got most of the under hood wiring finished minus the 3 wires for the ac. I made some caps to put in plugs I won’t be using anymore, like alternator and one headlight plug for to using a relay harness. I had some extra scrap harness ends laying around that I could steal the plugs of. I pulled the wires and pins out of the scrap connectors then filled the bottom ends with silicone to keeps dirt and water out. Today I put on both fenders and hood put back on today. Along with the final door adjustments. I still need to paint the top of the hood but can’t decide if I want to go just body color or black out the center. 

4A92C5D5-C0F1-498F-9B9F-DD4DE05AD7A4.jpeg

1845931C-32C7-4B91-9149-2570ABADD84C.jpeg

FB7B566F-8A1F-4884-AFDB-6BB729FFB73B.jpeg

A96D74C6-5274-4C23-AB51-A7373A8780D7.jpeg

Share this post


Link to post
Share on other sites

I finished up 95% of the interior wiring this weekend. Also got the stereo installed and all wires up. Still need to install the speakers but the wires are ran and hooked up to the radio. I added courtesy lights in the back side panels so I’ll have more interior lights than just the front floor lights. Installed the carpet, a new 110amp alternator with circuit breaker, and wired a hidden kill switch inside the car. I still need to run a wire to my trunk light but ran out of wire. 

Share this post


Link to post
Share on other sites

Yeah I’ve been testing everything as I put it back together. So far the only thing I seem to have an issue with is the 12v switched power. It seems to work not not really. All the gauge lights work as do the dash lights but my radio has to have 12v battery and 12v switched. I’ve got the 12v battery for sure, tested with a meter and test light. The 12v switched I have it with a meter on the yellow and black wire and ground but not with a test light. Due to this my radio with light up but not power on and my turn signaled that work. I have led taillights and have the correct relay and the lights for the turn signals flash properly on the dash but are dim and the lights won’t light for turn signal. They work properly for brake and normal taillights. 

Share this post


Link to post
Share on other sites

Over the last few days I’ve got the radiator installed and hooked up, finished installing and wiring the ac system, hooked up the transmission cooling lines, cleaned and repainted my seat frames, disassembled the convertible frame and completely rebuilt and painted it, and installed the carpet. I also got all the electrical issues sorted out and everything works properly now. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...