Jump to content
Sign in to follow this  
Flanders

TKX transmission mount

Recommended Posts

I've got a TKX 5-speed going in, but have a few questions about the crossmember mount that came with the kit.  It's their "x-factor" mount.

image.png.ea35e25466573c33b140b2c897483042.png It's quite a different shape than the factory  mount, and instructions (should I choose to read them) are pretty vague.

I'm curious if the attachment points on the frame are on the front-side, or back-side of the original crossmember mounting position. Original mount, for reference:

image.png.9cc118abbc78087e903a531ecf061d3d.png

 

Was hoping someone can shed a bit of light, otherwise I'll just arse around with it and see what fits best once I have the engine+trans hanging in the right position.

Share this post


Link to post
Share on other sites

While I have no experience with a top loader or the tkx, I feel comfortable stating it goes behind the cross brace. The tkx is a longer transmission than the toploader, based upon the measurements I have seen online. The answer will be clear when you have the transmissions next to each other.

Share this post


Link to post
Share on other sites

I have a  TKX in my 70.  But I have a different transmission mount from those.  I have no idea what brand it is as it came with the car.  The first mount you showed should work just fine. 

 

 

Share this post


Link to post
Share on other sites

that above pic looks custom :D 

I've just attached the mount, and have a few notes for anyone else doing this.

I used this:

image.png.025171f2ad038de3ab78943849b1cef3.png

 

I had to clearance the corner of the mount a bit, above the elongated hole (left, in the pic).  Otherwise the bracket was hitting the old cross-member mounting point, preventing the bolt hole from lining up.  It does indeed go on the 'rear' side of the original crossmember mount.

Also found that this bracket is not compatible with the JBA H-pipe (for 351W, manual trans).   The right-hand side, lower corner of the mount (in above pic) hits the exhaust. 

 

image.png.ac2896653b4f4731094a163bb19c3e34.png

 

...so now I need exhaust work done again.  Or, I find another transmission mount that fits (the stock one won't work).

Share this post


Link to post
Share on other sites
On 1/23/2023 at 9:53 AM, Flanders said:

that above pic looks custom :D

Yeah, because it didn't fit right when I bought the car.  LOL   I had do some welding on it to get it to fit right.   Now it fits good. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...