Jump to content

smh00n

Members
  • Content Count

    170
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by smh00n

  1. Hold the phone! Made a call to a decent brake shop, lovely lady looks up her catalogue and says I'll have 2 x 3/4" cylinders here tomorrow. So I'll give them a go and see how we fare.
  2. Thanks Stangs. I have found one part of the issue - my 6-month old wheel cylinders have rust through them. The old fluid must have had water in it. cars barely been driven whilst I sort this brake stuff out. I've ordered new ones and will flush the system completely to clean it. In Aus, the correct fix it to use smaller cylinders, to take pressure out of the system. I am using 13/16" or 20.64mm wheel cylinders. I think ideally 5/8" ones would fix it, or 3/4" at a pinch. Anyone know of a car that has cylinders in this size? To sleeve them is pretty dear here - about US$150 a pair. Otherwise that valve might do. That will make the 3rd set-up for the car :( Dumb question #2; how do you get the prop valve piston centred? I made up my own bolt but wondering how you ensure the valve is centred. Bit hard to see down there as well.
  3. The second valve in the pictures is listed as 68-69 only. 70 have the style at the top. Are you saying the 68-69 with the angled valve piped in is what I need??
  4. Thanks guys. My confusion is with the distribution block; I have bought one the same as the one in the top picture, but without the valve and piping. It takes the fluid from the 2 outlets on the master and splits it 2 ways to the front and one to the rears. It has the brake light switch in the body, so I assume this is also a proportioning valve. Barnett, the calipers are same diameter as the OEM Mustang ones and the fronts have never been an issue. With the booster, the feel is as good as you can expect so I don't think that's the issue. My problem is only in the rear. Maybe I need to try a doctors forum??? I didn't mention, the rear brakes are 10" x 1.75". I went to the smallest cylinders I could find (7/8"). Next step down is 5/8" but that's a $200 investment. I think I have the standard 13/16"? - 29/32"? in there now so could try the 7/8" again. I'll check today. Barnett the rears lock from dead cold and I've not got them hot. Another test I did was to put on a local master cylinder (1" bore, inbuilt proportioning valve) with an adjustable valve on but that did very little to change the rear. (I have tried a lot of things to fix this). Doug, is the prop valve you mention the same as pictured? I have the one without the valve and piping. I have read that you need to lock the shuttle piston centred when bleeding the brakes. The Ford manual does not mention that so do I need to lock the shuttle piston off when bleeding? Today I will back off the brakes so no drag, check the cylinder sizing, pressure bleed the brakes and try it out. Watch this space.
  5. This is driving me a bit nuts. I'll try to give you all the issues so you can advise. I have got the brakes working pretty well, but is still locking 1 rear then the other, under harder braking. Fronts lock fine when banged on but the rears will grab on light applications. The right side locks first then left. This is an improvement over both locking at once. To give you an idea of when they lock, you're driving down the road at 30mph and some goose stops in front of you, meaning you have to hit the brakes not hard-god-damn-I'm-dead but enough to pull up quick. This is when I have rear brakes lock. 90% of the time it's fine but do you want to be in front of me when I use that last 10%? I have a 70 which I think was a drum brake, non boosted car. When I bought it, it had been converted to front discs with a booster. What I have done and found so far: 69 pedal and booster have been fitted. I have checked measurements and definitely a 69. Unsure if the pedal box is a 70; will this cause issues? Assuming not, then the pedal and booster match as I replaced them. The booster was new from a US ebay site, it does look the same as what came off. It is a dual diaphragm one and is the 69 with the drop down eye on the booster to pedal rod. Repro disc master cylinder fitted. The booster and master have been setup by a local brake shop with correct push rod depth. Braking seems normal. Pedal may be a tad soft but. The front calipers and rotors are probably from an Aussie Falcon. Very similar to the OEM calipers. Front brakes are not the issue; I can modulate their performance fine. Distribution block and piping replaced with a later, although similar, distribution block Standard 302 with about 80 horsepower :( C4 auto robbing a further 20 horses Bled multiple times via the up/down pedal method. Pedal feels OK, firm, not too much movement before brakes engage New brake cables New rear std wheel cylinders New rear shoes, radius ground to match the drums New fitting kit for the rear shoes Rear brakes adjusted by locking drums then pulling back so there is a little drag. I can spin the wheel but there is drag there. So, am I missing a residual valve somewhere? My workshop manual does not show anything like that But I don't know why a virtually stock brake car has these issues. When I got the car the brakes were total junk and locked up at will. All the changes I have made have improved it but I am now chasing this last issue. I am a perfectionist if you were wondering... So, my questions are: 1. Do I need to get the bolt to stop the distribution valve moving when bleeding? I have not done this so far. 1a. Will bleeding them with a pressure bleeder make a difference? I'll probably have to do this anyway as I am solo worker. 2. Does it need a proportioning valve? I see Cobranda has the block and valve but only up to 69. What changed in 70 to remove it?
  6. I need the clips that hold the finishing panel under the main grill to the lower front panel. Is the centre one the right one? And what part number?
  7. I want to update my stock gauges with new ones, like the NVU or Classic Instruments offerings. Any recommendations on what are better ones? I like the 4 dial setups better than the 6 dials.
  8. And now I have working gauges. But, the oil pressure gauge is pretty slow to react; it slowly comes up to pressure and not really moves when revved from idle. I have 4.8V at the gauges so the regulator is working. Is the slowness of the gauge normal? I will be putting a pretty good engine in this and don't want to know after is blows itself to pieces the oil pressure was low or off. Am toying with a set of New Vintage Instruments for it, or are the Dakota ones better? A 6 dial dash would be neat but I don't know I want 5" speedo and tach
  9. I've got 16. Is that in tolerance?
  10. I just replaced my circuit board with a Scott Drake one. My dash lights and the indicator lights now do not work (but the brake fail is lighting up when cranking - go figure) and none of the engine gauges are working; oil, temp and gas. I'm not sure if the dash lights worked before but the oil, temp and gas did. How can a dummy work out if the nuts/posts are in the right spot? Interior lights work on the light switch btw
  11. With the XB master you need a new internal push rod as it is shorter(?) than the Mustang one. I got Burt Brothers at Fairfield to set it all up, cost about 50 bucks with a new pushrod. I spent a lot of time chasing brake issues on mine so be prepared for hassles with rear lock ups and possibly having to put an adjustable valve on it. Real good work for an office worker I'm one too with a MIG but no way I am cutting up my thing.
  12. You should be able to through USPS. Otherwise I have a shipping company in FL that will ship it, all you have to do is post it to them.
  13. I need an original one of these, off a factory disc car. Preferably a decent one that can be used again and definitely not a 'similar to the original' aftermarket.' My car has nothing so I need the bracket as well and anything else :) I am in Australia so would need to have a price to post it here and unfortunately I'd have to pay by pay pal but will cover their fee's.
  14. I'm keen on the tail lights but would need a cost to post to Australia. Also, if you have the original disc brake distribution block how much for that?
  15. I'm up for the brake distribution block assuming it is OEM, and if it is factory air then the end registers if they are nice and tight
  16. I need a pair of the factory air conditioning vents/registers for the end of the dash on a 70 base model. Mine are rattly and loose so would like a nice tight pair or if there is a simple refurb process can someone enlighten me? I am in Sydney Australia so need postage to there please. Payment is probably easier by Paypal and happy to pay their expensive, rip off fee's my end.
  17. I'm not an expert but I read somewhere the 428 cars with a 4.30 were the drag pack? Super Cobra Jet?
  18. I'd be keen on the steering wheel if it is any good for a daily driver
  19. I smell gas from the tank. Has a new repro tank. I replaced the rubber hose which reduced it a bit but still have leakage. Have to check the hose clamps and filler neck to make sure they are OK. I thought maybe there was a filler panel behind the seat as it seems a bit weird that there is nothing to stop fumes coming in from the tank anyway. But I guess in 1970 that wasn't a big deal.
  20. Try as I might, the interweb has not given up any details on what seals the trunk compartment off from the passenger compartment when the rear seat is fixed on my '70 sportsroof. I want to stop gas fumes coming through from the trunk as much as I can, so was there a panel that did this? And if there was, who stocks new ones?
  21. I spent around $600 and a couple of hours fitting new booster and master cylinder and now the brakes are just about *perfect*. The old setup by the previous owner was scary bad and like a light switch, on or off. Then spent more buying all new emergency brake cables front to back. This thing better appreciate all my spending :)
  22. Jeepers. I am not taking the carpets up on mine, too scary I think :(
  23. Actually, it topped 1.05. Too bad I never needed anything. Went there in 2009 at 0.80c and going back this June at..... 0.80c probably. I need tie rod ends... over 80 bucks for Moog here
×
×
  • Create New...