Jump to content

1969Fstback

Members
  • Content Count

    539
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by 1969Fstback

  1. One thing to keep in mind, for GT conversion you have to run 18 inch wheels. Seems like 17 factory wheels would clear but not all after market.
  2. I have 69 drum spindles. I had to press the backer plate of the hub. I went with mustang Steve's GT brake brackets. If I remember right, I bought 2007 gt calibers (take offs) from ebay for about 125 shipped with pads. They came with the caliper brackets and all. I sourced rotors from some place, but they are 2007 rotors. All and all for brackets, calipers, rotors and all I got about 500 in the complete set. The Steve kit came with centering ring that goes on the hub and fills the gap between the rotor and the hub.
  3. Need 2 groove for 351w. It's a 69. Has same water pump as my 302. Passenger side outlet. Thanks
  4. I have 18x9's on front with 5.95 inch backspacing with 1 inch spacer, but I converted it to disc which brings the wheel out further. So not sure how much further the rotor brings it out. Can't remember what was mentioned on the mustang Steve sight about it. The back I am running 18x10's with 6.37 inch back spacing with no spacer. I did have to trim the bump stop bracket that sticks out a little.
  5. I picked up starter from one of the chain stores. Put it on. Started but stayed engaged. I had to shim mine to pull it back some. Did your old starter have a shim? If so may try removing it to see if it will engage further.
  6. I looked at a 68 yesterday a guy I know inherited. Wants to sell it. He was told it was 428 car. Sadly it was not. Was a 302 2v with 351 motor. Car was in about as many pieces as possible. But the body was in real good shape. I don't need another project. If it was 428 car I would have figured something out.
  7. Mine acted similarly a few years ago. My issue was a vacuum leak.
  8. Is this one of those deal where you've been driving it for 2 years without issue or just getting it running type deal?
  9. Just an observation but the springs have the same number of coils. The small block spring has more space between the coils. Just googling some big block springs from drake and such they also have 9 coils. I have no idea if that is scientific comparison or not. Just an observation.
  10. I have 18x10s with 275/35s and 6.37 in back space. My wheel if math is right would be out .23 inch further. But your rim being narrower your tire would stick out past rim and inch. So .78 inch out further. I have space without out the fender rolled but I'm lowered an inch. Inside you'd have no issues I don't think. Outside you be close to the tire hitting.
  11. https://www.summitracing.com/parts/clp-in38v60-c?seid=srese1&gclid=Cj0KCQjwl6LoBRDqARIsABllMSbSapwk6mZ73eycTOVVyeoYKMUlX9qMhCIkz0ITC9SNrA9A6DdG20UaAnwLEALw_wcB
  12. Google vacuum block. Brings up ton of various configurations.
  13. I don't have a pic, but when I was trying to find bows for a fast back, I found a site or youtube vid explaining that they are supposed to be color coded. Thus, an order of install based on color. From what I gathered the bows with the longest bent leg went in back and they went in order of the shortest leg up front. But that's coming from a foggy memory.
  14. I'll check that. I think I've narrowed down my issues. I had valve cover leak that was blowing back on exhaust. One fouled plug and looks like the bolts that go through valve cover is getting some oil bypassing and blowing on the headers. Seems like the bolts came with Teflon washers but not sure. But, plugs looked good so thinking smell is externa to the motor.
  15. I pulled 6 of the 8 plugs. Not rich, they looked real good actually. If anything more on lean side. I put vacuum gauge on it, running around 17. Rechecked the timing and floats. Everything looks good. I am going to check the pcv valve and other 2 plugs this evening.
  16. I'm getting a lot of smell when driving. Monday was fine parked it got in it Tuesday and it's like a different car. I'm going to pull some plugs tonight.
  17. I just swapped out my original 302 with another 302 a few weeks ago. Timing at 11 if I remember correctly. It's early 70's 302. It has a brand new summit cam, lifters, pushrods etc. I used my summit 500 carb. it ran great Monday. Got home popped hood to check things out. Noticed 1 wire on the distributor cap wasn't seated. Started up still ran great. Parked it, got in it yesterday could smell fumes badly. I checked the floats looked correct. I still haven't pulled the plugs to check them out. The one thing I noticed that was odd, I have aluminum valve covers which are flat on top and fairly tall. The bolts are counter sunk, and a few had oil in the holes. Seemed kind of odd. I am hoping to pull plugs tonight. See if it's rich or lean. Just stumped on what could have happened to cause it over night. Ideas?
  18. Sorry, trying to make joke with metric vs SAE. I'd live in that garage also if it were mine.
  19. Regardless of the spelling of tire. What does this 35mm deal represent? And can I live in your garage.
  20. We need it. Not a lot going on in progress thread. Put it in the garage forum. Per the definition "Talk about anything and everything that has nothing to do with mustangs or everything to do with mustangs. No technical questions."
  21. This needs a Project Progess thread. Or at least, what the build details look like.
×
×
  • Create New...